プロジェクト

全般

プロフィール

Vote #62982

未完了

Document versioning

Admin Redmine さんが3ヶ月前に追加. 3ヶ月前に更新.

ステータス:
New
優先度:
通常
担当者:
-
カテゴリ:
Documents_4
対象バージョン:
-
開始日:
2008/04/04
期日:
進捗率:

0%

予定工数:
category_id:
4
version_id:
0
issue_org_id:
991
author_id:
740
assigned_to_id:
0
comments:
26
status_id:
1
tracker_id:
2
plus1:
9
affected_version:
closed_on:
affected_version_id:
ステータス-->[New]

説明

I thought Redmine previously did this, but I might be mistaken... It would be great if there was a way to upload a new version of a document, and still retain the old one. Just sequential numbering, with upload timestamp, and uploading user would probably be fine. Maybe a comment field to allow description of what changed from the previous version. Redmine does so much else for project management so well, this would definitely be another great feature. If it's already there and I'm just missing it, please let me know.


journals

I had a similar request in (issue #800 - i've set its status to "resolved") but this is more straight-forward and, hopefully, implementable.
--------------------------------------------------------------------------------
Closed as duplicated of #991 at reporter request.
--------------------------------------------------------------------------------
(I'm a baka... forgot that duplicated issue are linked)
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
Any thing new in this issue?
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
> +1

--------------------------------------------------------------------------------
+1

My teammates and I were just discussing this feature in a hallway meeting. Is there any strategy at all for dealing with versioned documents?
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
I've been recently converting some Wiki pages to Documents, but this lack of version control makes me question whether this is really a good choice. So +1 for some sort of versioning strategy for documents.
--------------------------------------------------------------------------------
+1
I have been looking for a project management system that can include simple document management with versioning. So far sharepoint did that but I just dont like sharepoint. If redmine could implement this my organization would have accept redmine.
Also, If wiki can be used as documentation would be a real great function, and as Alvaro suggested, adding versioning to wiki will be very helpful
--------------------------------------------------------------------------------
Just also have a look at a similar discussion in "Forum":/boards/4/topics/16028?r=16150#message-16150.
<pre>
Beyond the ui discussion, can you use a common and established scm or other dms service to save and handle the versioning and metadata handling around the files?
Most people won't like to save their file and history to new kind of system. The task "versioning of files" is already done and there are enough good standars to use or build on.

Some thinking and ideas..
In our case we use as scm Subversion and advanced integration via webdav. The problem is that we would need a business analyst compatible frontend for uploading (crud), versioning, watching changes and managing project documentation beyond code (there our coders use svn clients on svn server behind redmine).

You could use the standard scm configured in project archiv or embedd a defined one for saving the versions of files and docs.

In the case of using svn with adavanced redmine integration, you already have webdav on svn. Now you "only" need a nice frontend so some special folders on svn repo where you manage the docs and files for your project.
</pre>
--------------------------------------------------------------------------------
+1
This would be a killer feature for us. I just introduced Redmine primarily to track dev issues, but we are beginning to use more of its project management features. Lack of versioning is a big problem; we need an audit
trail of who changes documents, and some users are not tech-savvy in using another SCM system for documents.
I will have to set up a second wiki, such as FOSWIKI, which does versioning, and link to Redmine, but it would be much simpler to not have to do this.
--------------------------------------------------------------------------------
+1 ppl in my company cries over it...
--------------------------------------------------------------------------------
Aleksandar Pavic wrote:
> +1 ppl in my company cries over it…

You could also use SVN, which is intended for such purposes, you know?…
--------------------------------------------------------------------------------
What "Steve V":http://www.redmine.org/issues/991, and "Aaron Boxer":http://www.redmine.org/issues/991#note-15 explained with this feature request is what I exactly need.

I can't make non-tech people use & install SVN.
They just get URL to redmine with username/password and use it for collaboration on tasks & documents
on marketing projects.

Additional + would be to see all files ever uploaded on issues in files module, like #3995
--------------------------------------------------------------------------------
Aleksandar Pavic wrote:
> What "Steve V":http://www.redmine.org/issues/991, and "Aaron Boxer":http://www.redmine.org/issues/991#note-15 explained with this feature request is what I exactly need.
>
> I can't make non-tech people use & install SVN.
> They just get URL to redmine with username/password and use it for collaboration on tasks & documents
> on marketing projects.

I agree. Probably the ideal solution is to have the documentation module using a repo as back end for storing and versioning files, and providing a simple interface similar to the actual one as front end.

--------------------------------------------------------------------------------

> I agree. Probably the ideal solution is to have the documentation module using a repo as back end for storing and versioning files, and providing a simple interface similar to the actual one as front end.

Sure, I also agree that SVN is not the best option for non-technical people

#3071 addresses this topic of providing an external repository for storing and versioning such as Alfresco. But, so far, I've seen no progress.

Dealing with documents much easier, however, can be done through existing plugins such as #801. My colleague Xabier has been uploading changes these days to improve this plugin developed by Arnaud. I recomend it.

--------------------------------------------------------------------------------
Try a new DMSF plugin here http://www.redmine.org/plugins/dmsf. The plugin implements basic DMS features such as versioning, folder structure, multi upload, workflow,...
--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------


related_issues

relates,New,3995,Upgrade to "Files" module
relates,New,1196,Add versioning for Files and Documents
duplicates,Closed,800,Enable versioning for Documents and Files modules
duplicates,New,736,documents - directories and versions
duplicates,Closed,2555,Possibility for update Documents - version control

Admin Redmine さんが3ヶ月前に更新

  • カテゴリDocuments_4 にセット

他の形式にエクスポート: Atom PDF

いいね!0
いいね!0