プロジェクト

全般

プロフィール

Vote #63002

未完了

Add voting to tickets

Admin Redmine さんが3ヶ月前に追加. 3ヶ月前に更新.

ステータス:
New
優先度:
通常
担当者:
-
カテゴリ:
Issues_2
対象バージョン:
-
開始日:
2008/04/07
期日:
進捗率:

0%

予定工数:
category_id:
2
version_id:
0
issue_org_id:
1011
author_id:
574
assigned_to_id:
0
comments:
76
status_id:
1
tracker_id:
2
plus1:
37
affected_version:
closed_on:
affected_version_id:
ステータス-->[New]

説明

As I see lot of people voting for different tickets, I got idea why not to add voting to tickets.
Here is my rough idea:

  • Voting can be enabled/disabled per project/tracer ** so some projects will have no voting, some projects will have voting, but in some trackers (probably we don't vote in "bugs" tracker)
  • Every user can give only one vote per ticket ** so voting will be for registered users only (probably)
  • Proposal of voting model: ** Simple: you can vote (+1) or not vote (0) ** 1-5 model: you can select "how much" you vote: 5 = very much, 1 = maybe... ** -1,0,+1 model: you can vote in positive or negative way...
  • Each ticket will display voting score (numbers of points) and number of votes (this apply based on exact voting model)
  • When Nr. of votes and/of voting score will be added to ticket list's filters, we can list tickets by voting score or number of votes
  • Top 10 (5 etc) of most wanted issues can be displayed on homepage of project

What others think?


journals

I'd say +1 for this : )
--------------------------------------------------------------------------------
Yes, +1 for me too ;)
--------------------------------------------------------------------------------
+1. May be a good candidate for a plugin.
--------------------------------------------------------------------------------
+1 from me, too
--------------------------------------------------------------------------------
+1 here.

(Hey! We are VOTING here... Nice hack. :) )
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+1. See http://www.uservoice.com/ for a clean example of simple issue-voting.
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+1. This would be a really great feature!
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+1 !

--------------------------------------------------------------------------------
+1 great!
--------------------------------------------------------------------------------
I believe simple model of voting will be the best.. Coz 5 stars and -1,0,+1 are weird..
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+1 I could use it.
--------------------------------------------------------------------------------
Here's something that is 'sort of working for me': change the 'Issue priorities' Enumerations to [..., -1, 0, +1, +2, +3, ...] (as many as you need). This had the side-effect of making the 'priority' more relevant as well.

Then, the task would be to allow a non-manager 'user' to change the priority (explicitly?). Maybe 'voting' is a simple rule: a (non-manager/developer) 'user' can only change the priority, once, by one increment or decrement.

I was just toying with this solution as a workaround tonight, but thought it was interesting to implicitly tie the 'votes' to the 'priority' of an issue. Then the issues that are the 'squeakiest wheels' will automatically get the highest priorities.
--------------------------------------------------------------------------------
Like the idea and its description.

But that's another layer of cmoplexity: including it would move redmine closer to the bloated status :(

I preach for a plugin/module approach: let redmine admin add features they want to their very redmine, don't put all of them in it.

HTH
--------------------------------------------------------------------------------
I'll start some work for a plugin-implementation of issue-voting soon...
More to come...
--------------------------------------------------------------------------------
+1
I think this is a must have thing for every successful product aimed for end user!

On the first stages of product development when user community is small you may just write all users' suggestions to a paper sheet and easily see how many users want certain feature (this feature is wanted by 3 users and other features are wanted by only a one user, ok I'll do the first feature). But when the product community grows it's getting to hardly define what users want more. Without this feature you may think that users want EVERYTHING and RIGHT NOW! Having this feature allows us to plan what improvements we should implement first and what may wait for some time.
--------------------------------------------------------------------------------
huge +1. every professional, public software project needs this.
--------------------------------------------------------------------------------
notice that even redmine's issues are *littered* with +1 notes. those should all just be votes. every "+1" note in this system is a vote for ticket #1011.
--------------------------------------------------------------------------------
colin moock wrote:
> notice that even redmine's issues are *littered* with +1 notes.

lol, that's a good point
oh yea... +1 ;p
--------------------------------------------------------------------------------
"Andrew Chaika":http://www.redmine.org/account/show/4018 developed an issue-voting plugin which probably solves this issue. It can be found here on the forums: message#5506.
--------------------------------------------------------------------------------
Closing issue. Andrew Chaika has developed this in a plugin. See "my comment":http://www.redmine.org/issues/2104#note-10 for more information.
--------------------------------------------------------------------------------
What is the reason of not integrating this feature into trunk?
The best example is redmine.org itself, where users are voting constatnly still using comments.
If there would be necessity *not to* have voting - it should be possible to disable it in options.
What do you think?
--------------------------------------------------------------------------------
Or just activate the voting plugin on Redmine.
--------------------------------------------------------------------------------
James Turnbull wrote:
> Or just activate the voting plugin on Redmine.

That would be also a good solution, but if it is so desirable, why not to include it?
--------------------------------------------------------------------------------
I agree that issue voting be used on redmine.org either as the plugin or in trunk
to eliminate the need for voting in comments which incidentally I am doing now.
--------------------------------------------------------------------------------
+1 (this is horrible)
Isn't it possible to add this feature to Redmine.org (into the trunk or as a plugin)?
--------------------------------------------------------------------------------
It should be transparent to the comunity how ranking of features is. Else the future development can't be community driven.

+5 (new syntax - lol)
--------------------------------------------------------------------------------
+1 for activating this feature on redmine.org!!!
--------------------------------------------------------------------------------
+1 This should be in Redmine basic features !
--------------------------------------------------------------------------------
Are someone using this plugin with Redmine 1.2.0, where is it available to download ?
I Found only a updated up to 2009 in https://github.com/Ubik/redmine_vote !!
Is it abandoned ?
If so, we need to reopen this ticket !
--------------------------------------------------------------------------------
I nice guy forked the original redmin_vote plugin, and his fork is working for me. I'm running Redmine 1.2.1 on Ubuntu 10 with MySQL.
--------------------------------------------------------------------------------
Urmf. Sorry for the garbled previous post. Here's the link to the nice guy's fork of redmine_vote:

https://github.com/jimmyz/redmine_vote
--------------------------------------------------------------------------------
I am working on a fork with missing features
https://github.com/cforce/redmine_vote

* per project module which can be switched on/off
* added 3 rights
** vote_issue
** view_votes
** view_voters
separated view from hook code, no more inlining
TODO:
* fix #2 bug for public projects
* establish view_rights for issues vote patch
* provide filters for issue search

--------------------------------------------------------------------------------
Sascha Herrmann wrote:
> +1 for activating this feature on redmine.org!!!

I will do the same:
+1 for activating this feature on redmine.org!!!
--------------------------------------------------------------------------------
+1 for activating this feature on redmine.org
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
Since the "vote plugin" referenced as reason for closing this issue hasn't been maintained in over 3 years. I strongly urge this feature be reopened and reconsidered as part of redmine core. This is a essential feature, trac even has it as part of there official tracker. This is a must have for any large organisation or public project.

EDIT: also I think all everyone would appreciate this over spamming "+1" for everything.
--------------------------------------------------------------------------------
More "+1" spam!
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+1 relates to #11655 and #6945.
--------------------------------------------------------------------------------
+1

one way i'd like to see this implemented is by simply displaying the number of watchers on an issue... we already have a voting system builtin, right there. plus it means that people that vote actually are involved in the issue because they receive updates. if they don't want to receive updates, maybe they don't care so much. :)
--------------------------------------------------------------------------------
There is a new plugin i found

https://github.com/dextra/redmine_issues_poll.git
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
“Yo Dawg, I herd you like +1, so I put a +1 in your +1 so you can +1 while you +1.”

+1 for the +1 feature

--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
Activate plugin so we are sure that it will be upgraded to future Redmine versions.
--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+1 (Unfortunately, I'm assuming the redmine devs will never be interested in adding this...)
--------------------------------------------------------------------------------
+1 (I'd vote for it, but I can't)
--------------------------------------------------------------------------------
+1 (if this is the kind of voting...)
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
I am also affected by this.

Btw., launchpad.net instead has a clickable
"This bug affects 34 persons. Does this bug affect you?".
--------------------------------------------------------------------------------
Alternatively, one can "Use Watcher Count as a poor man's Voting system" (issue #17288)

Btw., #11655 is a duplicate of this issue.

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+1
I hope it will be around rather sooner then later...
--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
+ 1
--------------------------------------------------------------------------------
+1

Hi,
Dear Developers, when this module will be create ?

*2008*-04-07 - it is not ok
This request already exists 8 years old
--------------------------------------------------------------------------------
We have always performed prioritisation of issues politically within the business and weight each channel with importance.

For example the sales team will never vote to have a db query optimised.

Priorities are extremely useful to a point but when you have queues with hundreds of items it is nice to have a group voting system to allow this to be taken into account.

The way I would love to see it implemented is that it would be a custom field, essentially an Integer type with vote controls assigned to it. i.e. Format type would be vote.

The default value could always be 0 and the following could be left out :

Min - Max length
Regular expression
Default value
Link values to URL

Other than that it could hopefully piggy back off the Integer type logic already in place.
--------------------------------------------------------------------------------
The possible design solution I had created for a duplicated issue Feature #24946 (it has a more detailed description of the feature request, is is actually not a full duplicate of the present issue, as it is about adding voting to the issue list, not to the issue view itself)

!likes.png!
--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
+1
--------------------------------------------------------------------------------
Max Johansson wrote:
> +1

See, this is beyond irony at this point. This issue is close to receiving about a hundred +1 comments, most of which are unnecessary noise for probably even more watchers that have been waiting for this issue to be fixed for over a decade now.

It's simply a matter of showing the number of watchers on an issue. How hard can that possibly be? :)

That said, I'm not using Redmine anymore, and so I will bid my fellow watchers farewellm, unwatch this issue and apologize for this final, ultimate mike drop:

+1

:)
--------------------------------------------------------------------------------
Antoine Beaupré wrote:
> unwatch this issue and apologize for this final, ultimate mike drop: +1 :)

LOL XD
--------------------------------------------------------------------------------


related_issues

relates,Closed,8299,Add "vote for this issue" button on issues
relates,New,6945,Add a voting system to help users help admins identify popular features/defects
relates,New,1158,Polls
relates,New,17288,Use Watcher Count as a poor man's Voting system on redmine.org
relates,New,24946,Issue rating (like button or vote up button)
duplicates,Closed,8478,Vote for feature
duplicates,Closed,11200,Creare a vote system for users requests
duplicates,Closed,16050,Add votes
duplicates,Closed,11655,Implementation of a Issue Voting

Admin Redmine さんが3ヶ月前に更新

  • カテゴリIssues_2 にセット

他の形式にエクスポート: Atom PDF

いいね!0
いいね!0